
CC3200 SimpleLink Wi-Fi and IoT Solution With
MCU LaunchPad Getting Started Guide

User's Guide

Literature Number: SWRU376D
June 2014–Revised March 2016



2 SWRU376D–June 2014–Revised March 2016
Submit Documentation Feedback

Copyright © 2014–2016, Texas Instruments Incorporated

Table of Contents

Contents

1 Introduction......................................................................................................................... 4
1.1 Prerequisites .............................................................................................................. 4

2 Getting Started ................................................................................................................... 5
2.1 Download and Install Software ......................................................................................... 5
2.2 Configure Board .......................................................................................................... 5
2.3 Update Service Pack .................................................................................................... 6

3 Compile, Download, and Debug ............................................................................................. 7
3.1 Option 1: Code Composer Studio (CCS) ............................................................................. 7
3.2 Option 2: IAR Workbench ............................................................................................. 16
3.3 Option 3: GCC ......................................................................................................... 22

4 Summary........................................................................................................................... 28
5 Acronyms Used.................................................................................................................. 29
Revision History.......................................................................................................................... 30
Revision History.......................................................................................................................... 30
Revision History.......................................................................................................................... 30

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D


www.ti.com

3SWRU376D–June 2014–Revised March 2016
Submit Documentation Feedback

Copyright © 2014–2016, Texas Instruments Incorporated

List of Figures

List of Figures
1 Jumpers on the CC3200-LAUNCHXL..................................................................................... 5
2 Device Manager.............................................................................................................. 6
3 Code Composer Studio v6 Setup.......................................................................................... 7
4 CCS App Center ............................................................................................................. 8
5 Select CCS Projects to Import ............................................................................................. 9
6 Select CCS Projects to Import............................................................................................ 10
7 Properties for ti_rtos_config............................................................................................... 11
8 Select SimpleLink Project ................................................................................................. 12
9 Editing common.h .......................................................................................................... 12
10 Target Configurations...................................................................................................... 13
11 Import Target Configuration............................................................................................... 13
12 Set as Default............................................................................................................... 14
13 Launch Tera Term ......................................................................................................... 14
14 Tera Term Serial Port Setup.............................................................................................. 15
15 Debug wlan_station ........................................................................................................ 15
16 Tera Term VT ............................................................................................................... 16
17 IAR Embedded Workbench IDE.......................................................................................... 17
18 Open simplelink.eww ...................................................................................................... 18
19 Rebuild the simplelink Project. ........................................................................................... 19
20 Editing common.h .......................................................................................................... 20
21 Select TI Stellaris Driver................................................................................................... 20
22 Launch Tera Term ......................................................................................................... 21
23 Tera Term Serial Port Setup.............................................................................................. 21
24 Debug Icon .................................................................................................................. 22
25 Tera Term VT ............................................................................................................... 22
26 Cygwin Setup ............................................................................................................... 23
27 Zadig Options ............................................................................................................... 24
28 Replace Driver .............................................................................................................. 24
29 Editing common.h .......................................................................................................... 25
30 Output Screen .............................................................................................................. 25
31 Debugging wlan_station ................................................................................................... 26
32 Tera Term VT ............................................................................................................... 26
33 Device Manager ............................................................................................................ 27

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D


4 SWRU376D–June 2014–Revised March 2016
Submit Documentation Feedback

Copyright © 2014–2016, Texas Instruments Incorporated

CC3200 SimpleLink™ Wi-Fi® and IoT Solution With MCU LaunchPad™
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User's Guide
SWRU376D–June 2014–Revised March 2016

CC3200 SimpleLink™ Wi-Fi® and IoT Solution With MCU
LaunchPad™ Getting Started Guide

This guide is intended to assist users in the initial setup and demonstration of the Getting Started with
WLAN Station application. The guide explains how to install an Integrated Development Environment
(IDE), and then compile, download, and debug Getting Started with WLAN Station.

SimpleLink, LaunchPad are trademarks of Texas Instruments.
Microsoft, Windows are registered trademarks of Microsoft.
Wi-Fi is a registered trademark of WiFi Alliance.

1 Introduction

1.1 Prerequisites
The user should have the following items:
• One CC3200-LAUNCHXL
• An 802.11b/g/n (2.4 GHz) Wireless Access Point (AP).
• A computer running the Microsoft® Windows® 7 or XP operating systems.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
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2 Getting Started

2.1 Download and Install Software
Download and install the following software:
• CC3200 SDK package.

– This guide assumes the use of the default installation folder C:\TI\CC3200SDK_1.2.0\.
• Tera Term (or similar software)

– Tera Term link: http://en.sourceforge.jp/projects/ttssh2/releases/

2.2 Configure Board
The jumpers on the CC3200-LAUNCHXL should be connected as shown in Figure 1. It may be necessary
to move a jumper from P58-VCC to SOP2.

Figure 1. Jumpers on the CC3200-LAUNCHXL

1. Connect the CC3200-LAUNCHXL to the PC using the provided micro-USB cable.
2. The CC3200-LAUNCHXL is now visible in the Device Manager as shown in Figure 2. Note the COM

port number that appears.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
http://www.ti.com/tool/cc3200sdk
http://en.sourceforge.jp/projects/ttssh2/releases/
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Figure 2. Device Manager

2.3 Update Service Pack
If the board is not already flashed with the service pack for SDK 1.2.0, the latest service pack for SDK
1.2.0 must be flashed on the CC3200. The latest service pack can be downloaded from
http://www.ti.com/tool/cc3200sdk. Refer to the UNIFLASH Quick start guide for details on flashing the
service pack to the CC3200
(http://processors.wiki.ti.com/index.php/CC31xx_%26_CC32xx_UniFlash#Service_Pack_Programming).

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
http://www.ti.com/tool/cc3200sdk
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3 Compile, Download, and Debug
The CC3200 SDK supports CCS 6.1.1, IAR 7.30, and GCC IDE/compiler. The example shown here is
Getting Started with WLAN Station, and performs the following functions:
1. Program restores WLAN configuration to factory default.
2. Switches to Station mode if the device is in AP mode.
3. Connects to the user's Access Point (default SSID is 'cc3200demo’). If the connection to the AP is

successful, the red LED (D7) switches on.
4. Pings the user's AP. If the ping test is successful, the green LED (D5) switches on.
5. Pings to www.ti.com to check Internet connectivity. If the ping test is successful, the orange LED (D6)

switches on.

This example uses a Real-Time Operating System (RTOS).

3.1 Option 1: Code Composer Studio (CCS)

3.1.1 Download and Install
Download and run the Code Composer Studio 6.1.1 (CCS) installation wizard (ccs_setup_win32.exe) from
http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v6. The program must be
Version 6.1.1.00022 or later. Select the Wireless Connectivity MCUs option for processor support. The
remaining options for the installer should be left as the default. Installation time is typically 20 minutes, but
can vary based on internet connection speed.

Figure 3. Code Composer Studio v6 Setup

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v6
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3.1.2 Install TI-RTOS for SimpleLink and CC3200 Support Package
Install TI-RTOS for SimpleLink from the CCS App Center:
1. Start CCS, and choose a Workspace folder where the projects will reside.
2. Open the App Center from the Help->Getting Started screen.
3. Search 'cc32xx' in the App Center to find 'TI-RTOS for SimpleLink' and 'CC3200 Add-On.'
4. Select TI-RTOS CC32XX
5. The CC3200 add-on should already be installed. If not, select it.
6. Press Install Software

Figure 4. CCS App Center

3.1.3 Import and Configure Project
1. Choose Project>Import CCS Projects from the menu.
2. Select the Browse button in the Import CCS Eclipse Projects dialog, and Select the directory

C:\TI\CC3200SDK_1.2.0\cc3200-sdk.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
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Figure 5. Select CCS Projects to Import

3. Select the wlan_station, driverlib, simplelink, oslib, and ti_rtos_config projects. Click Finish. For any
library import, do not check the 'Copy projects into workspace' option. This breaks the links from the
libraries to their dependencies. The wlan_station project is automatically copied to the workspace.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D


Compile, Download, and Debug www.ti.com

10 SWRU376D–June 2014–Revised March 2016
Submit Documentation Feedback

Copyright © 2014–2016, Texas Instruments Incorporated

CC3200 SimpleLink™ Wi-Fi® and IoT Solution With MCU LaunchPad™
Getting Started Guide

Figure 6. Select CCS Projects to Import

4. Select the ti_rtos_config project in Project Explorer, and select Project>Properties from the menu.
Under General, select the RTSC tab as shown in Figure 7. Select the latest versions of XDCtools and
TI-RTOS for SimpleLink (not shown in Figure 7). Also verify the platform is selected as
ti.platforms.simplelink:CC3200.

http://www.ti.com
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Figure 7. Properties for ti_rtos_config

5. Select the simplelink project and build it as shown in Figure 8.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
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Figure 8. Select SimpleLink Project

6. Select the ti_rtos_config project and build it.
7. Select the driverlib project and build it.
8. Select ti_rtos configuration for oslib project and build it.
9. Open the common.h file located at the path C:\TI\CC3200SDK_1.2.0\cc3200-sdk\example\common\.
10. Edit common.h to use the SSID, security type, and security key of the AP. Edit the macros

SSID_NAME, SECURITY_TYPE, and SECURITY_KEY to contain the AP information as shown in
Figure 9. The security types supported for this demo are WPA/WPA2 and Open. For Open security,
define SECURITY_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2 security, define it as
SL_SEC_TYPE_WPA. Alternatively, the SSID and security of the AP can be changed to match the
default (SSID: cc3200demo, Security: Open). For the SSID_NAME and SECURITY_KEY, the
quotation marks must remain as part of the macro definition.

Figure 9. Editing common.h

11. Save common.h.

http://www.ti.com
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12. Select the wlan_station project and build it.
13. The target configuration must be set before debugging from CCS. Navigate to View>Target

Configurations.

Figure 10. Target Configurations

14. Right-click on User Defined, select Import Target Configuration and select the file CC3200.ccxml from
C:\TI\CC3200SDK_1.2.0\cc3200-sdk\tools\ccs_patch\. Select the Copy files option when prompted.

Figure 11. Import Target Configuration

http://www.ti.com
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15. Set this new configuration as the default by right-clicking on the file name, as shown in Figure 12.

Figure 12. Set as Default

Caution: Only one FTDI board should be connected to the PC while CCS downloads code to the
device.

16. Launch Tera Term, and create a new serial connection to the CC3200 Launchpad COM port as shown
in Figure 13.

Figure 13. Launch Tera Term

17. In the menu, select Setup>Serial Port, and change the baud rate to 115200 as shown in Figure 14.

http://www.ti.com
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Figure 14. Tera Term Serial Port Setup

18. Launch application: select the wlan_station project in Project Explorer, then click the debug icon as
shown in Figure 15 to download code to the device and begin debugging. Press F8 to begin execution.

Figure 15. Debug wlan_station

19. If the CC3200 successfully completes all steps, the serial output appears as shown in Figure 16.

http://www.ti.com
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Figure 16. Tera Term VT

3.2 Option 2: IAR Workbench

3.2.1 Download IAR
The CC3200 SDK has been built and tested with IAR 7.30, and older versions of IAR projects might not
work properly on IAR 7.30. Most examples will only run with the fully licensed IAR Workbench.
1. Download IAR for ARM processors from the IAR System website, and install it using the installation

wizard.
2. If using IAR version 7.20 or earlier, copy the file C:\TI\CC3200SDK_1.2.0\CC3200-

sdk\tools\iar_patch\armLMIFTDI.dll into the folder C:\Program Files (x86)\IAR Systems\Embedded
Workbench 7.0\arm\bin (the user must replace the existing file).

3.2.2 Rebuild the SimpleLink Driver
1. Start IAR and select File>Open>Workspace from the menu.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
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Figure 17. IAR Embedded Workbench IDE

2. Open the simplelink project by navigating to C:\TI\CC3200SDK_1.2.0\cc3200-sdk\simplelink\ewarm
and opening simplelink.eww.

http://www.ti.com
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Figure 18. Open simplelink.eww

3. Rebuild the simplelink project by selecting Project>Rebuild All from the menu, as shown in Figure 19.

http://www.ti.com
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Figure 19. Rebuild the simplelink Project.

3.2.3 Rebuild, Download and Debug the WLAN Station Example
1. Open the wlan_station project by selecting File>Open>Workspace from the menu, navigating to

C:\TI\CC3200SDK_1.2.0\cc3200-sdk\example\ getting_started_with_wlan_station\ewarm, and opening
wlan_station.eww.

2. Open the common.h file located at the path C:\TI\CC3200SDK_1.2.0\cc3200-sdk\example\common\.
3. Edit common.h to use the SSID, security type, and security key of the AP. Edit the macros

SSID_NAME, SECURITY_TYPE, and SECURITY_KEY to contain the AP information as shown in
Figure 20. The security types supported for this demo are WPA/WPA2 and Open. For Open security,
define SECURITY_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2 security, define it as
SL_SEC_TYPE_WPA.

http://www.ti.com
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Figure 20. Editing common.h

4. Save common.h.
5. Rebuild the wlan_station project by selecting Project>Rebuild All from the menu.
6. The debugger must be configured to download code to the device. Select Project>Options from the

menu, and select the Debugger category. In the Setup tab, choose TI Stellaris as the driver, as shown
in Figure 21, and press OK.

Figure 21. Select TI Stellaris Driver

7. Launch Tera Term, and create a new serial connection to the CC3200 Launchpad COM port as shown
in Figure 22.

http://www.ti.com
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Figure 22. Launch Tera Term

8. In the menu, select Setup>Serial Port, and change the baud rate to 115200 as shown in Figure 23.

Figure 23. Tera Term Serial Port Setup

9. Click the debug icon as shown in Figure 24 to download code to the device and start debugging.
Select Debug>Go from the menu, or press F5 to begin execution.

http://www.ti.com
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Figure 24. Debug Icon

10. If the CC3200 successfully completes all steps, the serial output appears as shown in Figure 25.

Figure 25. Tera Term VT

3.3 Option 3: GCC
This section demonstrates the GCC setup only for the Windows environment. GCC installation requires
other dependencies to be installed to work with ARM-based devices.

3.3.1 Install Cygwin (Windows)
1. Download setup-x86.exe from http://cygwin.com/install.html and run it. Select the Install from Internet

option.
2. Specify a proxy if necessary, depending on the network.
3. Choose a download site (for example, http://mirrors.kernel.org).
4. Include the latest versions of the following packages in the Cygwin installation (in addition to those

included in the base installation):
• Archive/unzip
• Archive/zip
• Devel/autoconf
• Devel/automake
• Devel/libtool
• Devel/make
• Devel/subversion (Note: if using TortoiseSVN/Windows7, skip this file)
• Devel/gcc-core
• Devel/gcc-g++
• Devel/mingw-gcc-core
• Devel/mingw-gcc-g++
• Devel/mingw-runtime

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
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See Figure 26 for an example of selecting a package (as example: Devel/autoconf).

Figure 26. Cygwin Setup

5. The system will find dependencies. Press Next.
6. After a successful Cygwin installation, add its path (c:\cygwin\bin\) to the Windows environment

variable PATH by going into Control Panel>System>Advanced System Settings>Environment
Variables. Under System Variables, select PATH and press Edit. Append “;C:\cygwin\bin\” to the end of
the line and press Ok.

3.3.2 GNU Tools for ARM Embedded Processors
Download the latest version of gcc-arm-none-eabi-<version>-win32.exe from https://launchpad.net/gcc-
arm-embedded, and install under the Cygwin root directory (default: c:\cygwin) and add the path
<installation_dir>\bin (for example, c:\cygwin\4.9 2015q2\bin) to the windows PATH environment variable.

3.3.3 Open On-Chip Debugger (OpenOCD)
1. Download prebuilt openocd-0.9.0 for Windows from http://www.freddiechopin.info/download/category/4-

openocd and unzip the package to the Cygwin root directory (default: c:\cygwin).
2. Add the path for the openocd.exe (.\openocd-0.9.0\bin\) to the Windows PATH environment variable.
3. Download the Zadig USB installation driver from http://zadig.akeo.ie/.
4. Run the zadig_<version>.exe and install the WinUSB driver for USB<->JTAG/SWD (Interface 0)

debuggers (refer to Figure 27 and Figure 28). The IAR and CCS debugger do not work after this: the
drivers must be reconfigured to work with these (refer to Section 3.3.6).

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU376D
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Figure 27. Zadig Options

Figure 28. Replace Driver

3.3.4 Compile the GCC SDK Project
1. Open the common.h file located at the path C:\TI\CC3200SDK_1.2.0\cc3200-sdk\example\common\.
2. Edit common.h to use the SSID, security type, and security key of the AP. Edit the macros

SSID_NAME, SECURITY_TYPE, and SECURITY_KEY to contain the AP information as shown in
Figure 29. The security types supported for this demo are WPA/WPA2 and Open. For Open security,
define SECURITY_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2 security, define it as
SL_SEC_TYPE_WPA.

http://www.ti.com
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Figure 29. Editing common.h

3. Save common.h.
4. In the Cygwin terminal, change the directory to C:\TI\CC3200SDK_1.2.0\cc3200-sdk\

example\getting_started_with_wlan_station\gcc\ and run the following command:
make -f Makefile

Note that Cygwin uses forward slashes to separate the directories.
5. Go to <cc3200-sdk>\example\getting_started_with_wlan_station\gcc\ in the command prompt and run

following command:
make -f Makefile

6. This generates the wlan_station.axf file under the gcc\exe folder.

3.3.5 Target Connection and Debugging (GDB)
1. The OpenOCD configuration file for FTDI is present under the C:\TI\CC3200SDK_1.2.0\cc3200-

sdk\tools\gcc_scripts\ folder. To test the connection to the CC3200 FTDI Launchpad, navigate to the
<cc3200-sdk>\tools\gcc_scripts folder, run the following command at the Cygwin prompt window, and
check the output to see if the connection happened properly. Cygwin may need to be restarted before
this step.
openocd -f cc3200.cfg

See Figure 30 for the connection output screen while the CC3200 device is connected through GDB.

Figure 30. Output Screen

2. Press <ctrl>+c to return to prompt.
3. Copy the wlan_station.axf file found in C:\TI\CC3200SDK_1.2.0\cc3200-sdk\

\example\getting_started_with_wlan_station\gcc\exe\ to the directory C:\TI\CC3200SDK_1.2.0\c3200-
sdk\tools\gcc_scripts\.

4. Launch Tera Term, and create a new serial connection to the CC3200 Launchpad COM port.
5. To start debugging using GDB on CC3200, go to C:\TI\CC3200SDK_1.2.0\cc3200-

sdk\tools\gcc_scripts\ and run the following command at the Cygwin prompt:
arm-none-eabi-gdb -x gdbinit wlan_station.axf

http://www.ti.com
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Figure 31. Debugging wlan_station

This results in a GDB prompt. To continue, type ‘continue’ and press enter.
6. If the CC3200 successfully completes all steps, the serial output appears as shown in Figure 32. See

Figure 31 for the result of debugging the wlan_station application from GCC.

Figure 32. Tera Term VT

3.3.6 Driver Reconfiguration
1. To work with CCS or IAR, go to the device manager.

http://www.ti.com
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2. Update the driver software for USB<->JTAG/SWD (Interface 0) under Universal Serial Bus devices.
3. Select the <cc3200-sdk>\tools\ftdi folder for the driver update, as shown in Figure 33.

Figure 33. Device Manager
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4 Summary
After the development environment has been set up, refer to the following resources for further assistance
in development:
• CC3200 Programmer's Guide (SWRU369) – This guide contains information on how to use the

SimpleLink API for writing WLAN-enabled applications.
• PinMux Tool – This utility helps determine how to best assign peripherals to the appropriate CC3200

package pins.
• Uniflash – The Uniflash tool manually stores files on the external serial flash. This includes the

application binary and SimpleLink firmware patch files. Also, any configuration files, security
certificates, web pages, and so forth can be stored using this tool.

• CC3200 Wiki – All information and tools for the CC3200, including the above, can be found on the
CC3200 Wiki page.

http://www.ti.com
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5 Acronyms Used
STA – Wi-Fi Station

AP – Wi-Fi Access Point

WLAN – Wireless LAN

CCS – Code Composer Studio

GCC – GNU Compiler Collection
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